BTRFS issue mounting in fstb

I have a personal media server that for some reason or another I thought would be a good idea to use btrfs on the media – it was in my early days of Linux and I don’t exactly remember my reasoning for choosing btrfs, but essentially I could have used ext4 with LVG but I wasn’t aware of that. Anyways long story short it’s four 4TiB drives that are put together inside of some kind of VG. I don’t recall how I did it, though I’m pretty sure I found an article on How to Geek or Techmint and just walked through those steps. Fast forward 2.5 years and I decided to update from Centos 7 to Centos 8, thinking this shouldn’t be a problem (stupid me). After installing Centos 8 and realizing that they dropped btrfs support, I decided to move to Ubuntu 20.04.1, now when I try to mount the drives it’s like they have never been formatted. When I run:

sudo blkid 

It get the following:

/dev/sdb: PTUUID="9cd3ff7f-7c3c-4805-88b8-c3b800dc061a" PTTYPE="gpt" /dev/sdc: PTUUID="4c4fac1c-3eee-4c1e-9093-b47f64bdbb27" PTTYPE="gpt" /dev/sde: PTUUID="a6f19bd8-5c9c-4488-a11b-0451409b44a7" PTTYPE="gpt" /dev/sdd: PTUUID="e8a21df7-ced6-42ce-9899-4fef83ac6255" PTTYPE="gpt" 

When I run any of the btrfs commands It says it doesn’t see any btrfs drives. Nothing weird shows up in dmesg either. This has me entirely baffled. Worse case scenario I blow these drives away and start over, but I have about 8 TiB of media (TV Shows and Movies) that would prefer not to lose. If anyone has a solution on how I can mount these drives (or even documentation) it would be much appreciated.

Vice Professor Asked on October 26, 2020 in centos,   networking,   Windows.
Add Comment
0 Answer(s)

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.